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ABSTRACT : The world is becoming so much more unsafe for women. Social evils like molestations, dowry, crime 

against women, worst among all is rape is on the rise in many countries. Incidents of crime against women have been 

increasing at an alarming pace in Indian cities, most common incidents being rape, kidnapping, sexual harassment and 

eve teasing. Security for women is still a major issue as the number of crimes over women and girls is increasing day 

by day. In this age of technology, mobile phone is one gadget almost everyone uses to keep in touch with family and 

friends. All they need is a device that can be carried around easily and worn whenever the woman feels unsafe. 

Environment is one of the important yardsticks of its overall growth and progress. However, women safety and security 

has emerged as a key concern for the country over the recent years. Women from various walks of life face situations 

that make them feel threatened in different environments. In this project suggests a new perspective to use technology 

to protect women. The system resembles a smart device when activated, tracks the location of the victim using GPS and 

sends emergency messages (Global System for Mobile communication), to two emergency contacts and the police 

control room. 
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I. INTRODUCTION 
 

The modified system is to design portable device for the security of women. It consists of power supply, Arduino, 

touch sensor, tear gas, GPS and GSM mode. It is a distinct aid product designed to keep the user and their associate 

safe 24/7. It is filled with features for both everyday safety and real emergencies . Our aim is to provide you with 

firmest and natural way to connect your nearby hand. It share the current location and a heartache message to the cops 

and the emergency contacts, so that disastrous circumstance can be avoided. This is very useful to police department to 

compress the law-breaking, which are abuse. Emergency alert can prevent the victim from any physical or sexual 

assault .The device called as “Virtual Friend” is especially designed for the women in suffering. It is a device used for 

the women in confused situation. The basic approach of the use of arduino is sending and receiving data by the GSM 

shield provided in the arduino board. The current location of the object is identified by the GSM network using 

Arduino UNO by initiating the user’s smart phone. At once the Arduino UNO gets the directs of the current location 

the Arduino transfers the coordinate details to the user’s smart phone via Arduino GSM shield. The SOS light is a 

signal used to alert the person walking by and it gives the sign of universal help to the victim. The alarm buzzer is 

activated if the woman is in threat location. At times of critical situations the woman can send message or make a call 

to the registered contacts via GSM and GPS. Even the device is lost, the call and the message is sent till the user picks 

up or view the text message. This is exactly where the government needs to step in and try and diminish cost and 

infrastructure issues for the corporations working in this direction. 

 

1.1 HARDWDARE ARCHITECTURE  
1.1.1 ARDUINO 

Arduino interface boards provide the engineers, artists, designers, hobbyists and anyone who tinker with 

technology with a low-cost, easy-to-use technology to create their creative, interactive objects, useful projects etc., A 

whole new breed of projects can now be built that can be controlled from a computer. 
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Fig- 1: Arduino 

1.1.2    BATTERY 
The Arduino Uno can be powered via the USB connection or with an external power supply. The power 

source is selected automatically. External (non-USB) power can come  from battery. The adapter can be connected by 

plugging a 2.1mm center-positive plug into the board's power jack. Leads from a battery can be inserted in the Gnd and 

Vin pin headers of the power connector. The board can operate on an external supply of 6 to 20 volts. If supplied with 

less than 7V, however, the 5V pin may supply less than five volts and the board may be unstable. If using more than 

12V, the voltage regulator may overheat and damage the board. The recommended range is 7 to 12 volts.  

 
Fig-2: Battery 

 
1.1.3      PUSH BUTTON 

A push button is a type of electrical switch that is operated by pressing a button. It is a momentary switch that 

makes or breaks an electrical connection while the button is being pressed. When the button is released the switch 

returns to its original position and the connection is broken. 

 
Fig-3: Push Button 

1.1.4 GSM MODULE 
  Global system for mobile communication (GSM) is a globally accepted standard for digital cellular 

communication. GSM is the name of a standardization group established in 1982 to create a common European mobile 

telephone standard that would formulate specifications for a pan-European mobile cellular radio system operating at 

900 MHz. 

 
Fig-4: GSM Module 
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1.1.5 GPS TRACKER 
The Global Positioning System (GPS) is a Global Navigation Satellite System (GNSS) developed by the 

United States Department of Defense. It is the only fully functional GNSS in the world. It uses a constellation of 

between 24 and 32 Medium Earth Orbit satellites that transmit precise microwave signals, which enable GPS receivers 

to determine their current location, the time, and their velocity. Its official name is NAVSTAR GPS. Although 

NAVSTAR is not an acronym, a few backronyms have been created for it. The GPS satellite constellation is managed 

by the United States Air Force 50th Space Wing. GPS is often used by civilians as a navigation system. 

 

 
Fig-5: GPS Tracker 

 

1.1.6 DC-DC CONVERTER 
  

DC-to-DC converters are electromechanical devices or electronic circuits that convert one direct 

current voltage or current level to another. In most cases, devices use only one power source. However, if 

different sub-circuits require different voltages to work properly, one needs to convert the input voltage to a 

lower or higher level. That can be done with DC-DC converters. Additionally, they stabilize voltages, not 

letting them drop or rise too much. For example, one of the purposes of car DC-DC converters is to regulate 

the voltage fluctuations in automotive alternators  

 

 
Fig-6: DC-DC Converter 

 

1.1.7 VOLTAGE COMPARATOR 
A voltage comparator is an electronic device designed to compare the magnitudes of two voltages. It takes two 

inputs, compares them, and provides a binary output that indicates which of the input voltages is higher. 

 

 
Fig-7: Voltage Comparator 
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1.2 OBJECTIVE 
 The main purpose of this device is to act as an emergency device for women who are in potential danger of 

being attacked. 

● To contribute and take positive steps to protect women 

● To find the location and also send a alert message to your friends, family, or concerned person in dangerous 

situation 

 

       1.3 SOFTWARE DESCRPTION 
 The Arduino Software (IDE) makes it easy to write code and upload it to the board offline. We recommend 

it for users with poor or no internet connection. This software can be used with any Arduino board.  

 There are currently two versions of the Arduino IDE, one is the IDE 1.x.x and the other is IDE 2.x. The IDE 

2.x is new major release that is faster and even more powerful to the IDE 1.x.x. In addition to a more 

modern editor and a more responsive interface it includes advanced features to help users with their coding 

and debugging. 

 

The following steps can guide you with using the offline IDE (you can choose either IDE 1.x.x or IDE 2.x):  

1. Download and install the Arduino Software IDE: 

2. Connect your Arduino board to your device. Open the Arduino Software (IDE). 

3. The text editor for writing your code. 

4. The text console displays text output by the Arduino Software (IDE), including complete error messages and other 

information. Connect your Arduino or Genuino board to your computer. 

6. Now, you need to select the right core & board. This is done by navigating to Tools > Board > Arduino AVR 

Boards > Board. Make sure you select the board that you are using. If you cannot find your board, you can add it 

from Tools > Board > Boards Manager. 

7. Now, let's make sure that your board is found by the computer, by selecting the port. This is simply done by 

navigating to Tools > Port, where you select your board from the list. 

8. Let’s try an example: navigate to File > Examples > 01.Basics > Blink. 

9. To upload it to your board, simply click on the arrow in the top left corner. This process takes a few seconds, and 

it is important to not disconnect the board during this process. If the upload is successful, the message "Done 

uploading" will appear in the bottom output area. 

10. Once the upload is complete, you should then see on your board the yellow LED with an L next to it start 

blinking. You can adjust the speed of blinking by changing the delay number in the parenthesis to 100, and upload 

the Blink sketch again. Now the LED should blink much faster. 

 
II. SCOPE AND STUDY 

 

The gadget can be connected to current safety infrastructure, including police stations, emergency response 

teams, and hospitals. As a result, emergency response times might be sped up. The tool is capable of establishing a 

network for community safety. This can be done by connecting various devices to a main server that is under the 

control of a security team. The security team can then respond to crises by dispatching assistance to the device's 

location. Safety for remote workers: The tool can be used to guarantee safety for field workers, delivery drivers, and 

other remote workers. The gadget can be set up to recognize when a worker deviates from their intended path. The 

gadget is compatible with accessories like fitness bands and smart watches. This may make it possible to check the 

wearer's safety continuously. Integration with additional sensors: The system can be connected to additional sensors, 

including those that measure temperature, humidity, and air quality. As a result, the device may be able to identify 

dangerous situations and alert the wearer to take extra care. 

 

III. COMPONENTS 
 
1.Arduino 

2.GSM module 

3.GPS tracker 

4.DC-DC converter 

5.Push button 

6.Battery 

7.Voltage Comparator 
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IV. BLOCK DIAGRAM 
 

 
 

Fig -8: Block Diagram 

 
V. WORKING 

 
         In this paper there is a push button when any woman press that button then the whole functioning will be start. All 

the components are connected to the Arduino uno and for the power supply (battery) also needful. GPS will give the 

location of that place where the woman is in trouble. “I am in trouble please help me” is send by the GSM in the 

message form to the registered number. Message is sending or sent to the specific number and person who gets the 

message can be reach on that location easily by the help of their location. 

 

VI. RESULT AND DISCUSSIONS 
 

This segment talks about the consequences of the three methods of activity of the gadget and the potential 

incorporations to the gadget to improve its abilities. 

 

     6.1      Location 
  Send mode As this mode is initiated by the press button, it takes 7 seconds to acquire the directions and 

messages are sent to the confided in contacts inside interims of 4 seconds. The message contains a hyperlink which 

coordinates the beneficiary straightforwardly to google maps where the area of beginning of the pain message will be 

shown. 

 

 
Fig-9: Device sends coordinates to recipient 

 
6.2    Outcome 

  The device will be able to recognize the person from a range, its location will be tracked with the help of GPS 

sensor, All this information will be passed to the specific person's phone via GSM module. 
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Fig -10: Hardware Kit 

 

VII. CONCLUSION 
 

This project plays a crucial role in ensuring Women's Safety in the fastest way possible automatically. The 

proposed design will deal with critical issues faced by women in the recent past and will help solve them through 

technologically sound gadgets. With further research and innovation, this project can be implemented in different areas 

of security and surveillance. The system can perform real-time monitoring of the desired area and detect the violence 

with good accuracy. 
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